Armbian安装配置

本文章记录armbian装机配置,以root用户登录进行操作,处理一些奇奇怪怪的问题和bugarmbian-insatll no 前一定要 ls -l / 检查所有者是不是1023如果是,重做启动盘再装实测通过 find / -gid 1023 -uid 1023 -exec chown root:root {} \; 的方式找出来改掉还会有其他的问题,不要把启动盘往Android上乱插定义变量e

- 阅读全文 -

最简单的方式在linux中编译安装Python3

众所周知,目前还有很多的服务器用着CentOS7,虽然他已经凉了,这些服务器通常都是不联网的,那么就需要编译安装,此时补齐依赖包在没有能联网的跳板机的socks5代理给yum使用的情况下,将是一件十分痛苦的事情。特别是OpenSSL,依赖巨多,那么这时候应该怎么办呢,那就用LibreSSL吧,恰好Python3是支持的,于是就有了下面愉快的操作先去 Python官网 和 LibreSSL镜像 下载

- 阅读全文 -

Struts2.3升级到2.5.30

众所周知,Struts2经常被爆出一些奇奇怪怪的大漏洞,并且Struts2.3和Struts2.5是两个不同的分支,就像Python2.7和Python3一样,并且Struts2.3的分支在2018年已经停止维护了,想要修复漏洞那么只能做大版本升级。本次为远程执行漏洞CVE-2021-31805(S2-062),由于版本差距悬殊,用时一天半,现在记录一下改了什么。

- 阅读全文 -

Python3打开新shell并进行多次交互

这时候有人要说了,执行shell用os.system()就行了嘛需要返回值用subprocess.Popen().communicate()嘛但是如果需要多次交互,就需要使用下面这种方法import subprocess import os ssh = subprocess.Popen('ssh [email protected]', shell=True, stdout=

- 阅读全文 -

Python3 urllib 怎么POST Json

outData = urllib.request.urlopen(urllib.request.Request(url, headers={'content-type': 'application/json'}), json.dumps(jsonData).encode('utf-8'))jsonObject = json.loads(o

- 阅读全文 -

备份ESP固件

首先装好Python3下载一个esptool.py去设备管理器看一下usb串口是那一个号(此处是COM69,下面请自己换掉别傻傻的复制)在esptool.py同级目录打开cmd容量1m:python esptool.py --baud 115200 --port COM69 read_flash 0x00000 0x100000 dump.bin容量4m:python esptool.py --b

- 阅读全文 -

Kindle网易云音乐

这是一个kual插件,需要越狱kindle,可以实现在kindle上使用otg接usb声卡播放网易云歌单的内容这是之前做出来的,比较简陋,有人需要那就花了点时间整理出来依赖有两个kterm(用于显示alsamixer调节音量,压缩包中已包含)python3(主程序运行支持,可以参考 Kindle Voyage越狱 下载k5的python进行安装,太大了服务器有点hold不住不传上来了)剩下的只需要

- 阅读全文 -

GPD Pocket 2

B站 郑羊羊放了一个开箱测评和GTA5测试的视频最近众筹买了一台Pocket 2来代替我的平板我买的是4g版本发现8g是镁光白片而4g是镁光正片贫穷限制了内存大小手上这台是白色电源灯的左边的USB实际上是2.0屏幕转轴左边先着地手指鼠标左边有点刮手(剪刀解决)众筹价格3499送一个皮套到货一周后退100目前已实现:没有hidpi的Ubuntu 18(其实实现了但是鼠标移不到右下角已实现基础显示缩放

- 阅读全文 -

最新文章

最近回复

  • 咩咩: 这没有绝对的对与不对,不同的硬件地址可能就不一样,我的就是在这里...
  • Kang: 我用PVE7.2-3折腾了J4125两天,不行。一启动虚拟机PV...
  • Kang: cd /sys/bus/pci/devices/0000:02:...
  • 幸运星呐: 咩咩厉害。
  • 大神指点: 哎失败了,没能保留ssh,坐等大神更新了
  • kumax: 谢谢帮助,我再试试
  • 咩咩: 你网有问题,建议先处理好网络再装,这个包确实是存在的
  • kumax: 我的系统是n1安装的openwrt,是符合aarch64的要求的...
  • kumax: 22-12-02 12:49:27 ERROR (SyncWor...
  • 咩咩: 那你的系统究竟是什么架构的呢?

分类

标签